maven项目编译提示jdk版本低解决办法

在pom文件build节点中添加这个就可以,jdk版本可以指定

<build>
    <pluginManagement>
            <plugins>
                <!-- 负责编译的maven插件 -->
                <plugin>
                    <groupId>org.apache.maven.plugins</groupId>
                    <artifactId>maven-compiler-plugin</artifactId>
                    <version>3.8.0</version>
                    <configuration>
                        <source>1.8</source>
                        <target>1.8</target>
                        <encoding>UTF-8</encoding>
                    </configuration>
                </plugin>
            </plugins>
    </pluginManagement>
</build>
Last modification:October 14th, 2019 at 07:40 pm
如果觉得我的文章对你有用,请随意赞赏

Leave a Comment